mbox

[v2,00/19] spi: Convert MPC8XXX to DM

Message ID 20190428202854.8590-1-jagan@amarulasolutions.com
Headers

Message

Jagan Teki April 28, 2019, 8:28 p.m. UTC
This would be next version mpc8xxx dm conversion.

No functional changes in v2 apart from rebase, and this would
merge soon.

Changes for v2:
- rebase on master
- patch for SPI MIGRATION status

Any inputs?
Jagan.

Jagan Teki (2):
  spi: mpc8xxx: Convert to DM
  dm: MIGRATION: Update migration status for SPI

Mario Six (17):
  spi: mpc8xxx: Use short type names
  spi: mpc8xxx: Fix comments
  spi: mpc8xxx: Rename camel-case variables
  spi: mpc8xxx: Fix space after cast
  spi: mpc8xxx: Fix function names in strings
  spi: mpc8xxx: Replace defines with enums
  spi: mpc8xxx: Use IO accessors
  spi: mpc8xxx: Simplify if
  spi: mpc8xxx: Get rid of is_read
  spi: mpc8xxx: Simplify logic a bit
  spi: mpc8xxx: Reduce scope of loop variables
  spi: mpc8xxx: Make code more readable
  spi: mpc8xxx: Rename variable
  spi: mpc8xxx: Document LEN setting better
  spi: mpc8xxx: Re-order transfer setup
  spi: mpc8xxx: Fix if check
  spi: mpc8xxx: Use get_timer

 doc/driver-model/MIGRATION.txt |   6 +-
 drivers/spi/Kconfig            |  10 +-
 drivers/spi/mpc8xxx_spi.c      | 279 ++++++++++++++++++++++-----------
 3 files changed, 194 insertions(+), 101 deletions(-)